<!DOCTYPE html>
<html lang="en-GB">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<title>Emulating MVS Mainframe on Raspberry PI - peppe8o</title>
<script data-phast-original-type="text/javascript" type="text/phast">function theChampLoadEvent(e){var t=window.onload;if(typeof window.onload!="function"){window.onload=e}else{window.onload=function(){t();e()}}}</script>
<script data-phast-original-type="text/javascript" type="text/phast">var theChampDefaultLang = 'en_GB', theChampCloseIconPath = 'https://peppe8o.com/wp-content/plugins/super-socializer/images/close.png';</script>
<script type="text/phast">var theChampSiteUrl = 'https://peppe8o.com', theChampVerified = 0, theChampEmailPopup = 0;</script>
<script type="text/phast">var theChampFBKey = '', theChampFBLang = 'en_GB', theChampFbLikeMycred = 0, theChampSsga = 0, theChampCommentNotification = 0, theChampHeateorFcmRecentComments = 0, theChampFbIosLogin = 0;</script>
<script data-phast-original-type="text/javascript" type="text/phast">var theChampFBCommentUrl='https://peppe8o.com/emulating-mvs-mainframe-on-raspberry-pi/';var theChampFBCommentColor='';var theChampFBCommentNumPosts='';var theChampFBCommentWidth='100%';var theChampFBCommentOrderby='';var theChampCommentingTabs="wordpress,facebook,disqus",theChampGpCommentsUrl='https://peppe8o.com/emulating-mvs-mainframe-on-raspberry-pi/',theChampDisqusShortname='',theChampScEnabledTabs='wordpress,fb',theChampScLabel='Leave a reply',theChampScTabLabels={"wordpress":"Default Comments (0)","fb":"Facebook Comments","disqus":"Disqus Comments"},theChampGpCommentsWidth=0,theChampCommentingId='respond'</script>
<script type="text/phast">var theChampSharingAjaxUrl='https://peppe8o.com/wp-admin/admin-ajax.php',heateorSsFbMessengerAPI='https://www.facebook.com/dialog/send?app_id=595489497242932&display=popup&link=%encoded_post_url%&redirect_uri=%encoded_post_url%',heateorSsWhatsappShareAPI='web',heateorSsUrlCountFetched=[],heateorSsSharesText='Shares',heateorSsShareText='Share',theChampPluginIconPath='https://peppe8o.com/wp-content/plugins/super-socializer/images/logo.png',theChampHorizontalSharingCountEnable=0,theChampVerticalSharingCountEnable=0,theChampSharingOffset=-10,theChampCounterOffset=-10,theChampMobileStickySharingEnabled=1,heateorSsCopyLinkMessage="Link copied.";var heateorSsHorSharingShortUrl="https://peppe8o.com/emulating-mvs-mainframe-on-raspberry-pi/";var heateorSsVerticalSharingShortUrl="https://peppe8o.com/emulating-mvs-mainframe-on-raspberry-pi/";</script>
<style>.the_champ_horizontal_sharing .theChampSharing{color:#fff;border-width:0px;border-style:solid;border-color:transparent;}.the_champ_horizontal_sharing .theChampTCBackground{color:#666;}.the_champ_horizontal_sharing .theChampSharing:hover{border-color:transparent;}.the_champ_vertical_sharing .theChampSharing{color:#fff;border-width:0px;border-style:solid;border-color:transparent;}.the_champ_vertical_sharing .theChampTCBackground{color:#666;}.the_champ_vertical_sharing .theChampSharing:hover{border-color:transparent;}@media screen and (max-width:783px){.the_champ_vertical_sharing{display:none!important}}div.heateor_ss_mobile_footer{display:none;}@media screen and (max-width:783px){i.theChampTCBackground{background-color:white!important}div.the_champ_bottom_sharing{width:100%!important;left:0!important;}div.the_champ_bottom_sharing li{width:14.285714285714% !important;}div.the_champ_bottom_sharing .theChampSharing{width:100% !important;}div.the_champ_bottom_sharing div.theChampTotalShareCount{font-size:1em!important;line-height:28px!important}div.the_champ_bottom_sharing div.theChampTotalShareText{font-size:.7em!important;line-height:0px!important}div.heateor_ss_mobile_footer{display:block;height:40px;}.the_champ_bottom_sharing{padding:0!important;display:block!important;width:auto!important;bottom:-2px!important;top:auto!important;}.the_champ_bottom_sharing .the_champ_square_count{line-height:inherit;}.the_champ_bottom_sharing .theChampSharingArrow{display:none;}.the_champ_bottom_sharing .theChampTCBackground{margin-right:1.1em !important}}</style>
<meta property="og:title" content="Emulating MVS Mainframe on Raspberry PI"/>
<meta property="og:description" content="Wikipedia Mainframe Computer page defines Mainframe as following:
Mainframe computers or mainframes (colloquially referred to as &quot;big iron&quot;) are computers us"/>
<meta property="og:image" content="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-emulation-featured-image.jpg"/>
<meta name="twitter:card" content="summary">
<meta name="twitter:title" content="Emulating MVS Mainframe on Raspberry PI"/>
<meta name="twitter:description" content="Wikipedia Mainframe Computer page defines Mainframe as following:
Mainframe computers or mainframes (colloquially referred to as &quot;big iron&quot;) are computers us"/>
<meta name="twitter:image" content="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-emulation-featured-image.jpg"/>
<meta name="author" content="peppe8o"/>
<meta name="description" content="Emulating Mainframe MVS on Raspberry PI to reproduce a vintage enterprise system in your credit card sized computer. Create your first dataset with TSO."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://peppe8o.com/emulating-mvs-mainframe-on-raspberry-pi/" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://peppe8o.com/emulating-mvs-mainframe-on-raspberry-pi/" />
<meta property="og:site_name" content="peppe8o" />
<meta property="article:tag" content="hercules" />
<meta property="article:tag" content="mainframe" />
<meta property="article:tag" content="MVS" />
<meta property="article:tag" content="raspberry pi" />
<meta property="article:tag" content="raspbian buster lite" />
<meta property="article:tag" content="TK4" />
<meta property="article:tag" content="TSO" />
<meta property="article:section" content="raspberry" />
<meta property="article:published_time" content="2020-02-28T18:40:57+00:00" />
<meta property="article:modified_time" content="2020-02-28T18:45:19+00:00" />
<meta property="og:updated_time" content="2020-02-28T18:45:19+00:00" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@peppecassibba" />
<meta name="twitter:creator" content="@peppecassibba" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":["Person","Organization"],"@id":"https://peppe8o.com/#/schema/person/758b44898a41588ed5cfe04a6a583b13","name":"peppe8o","image":{"@type":"ImageObject","@id":"https://peppe8o.com/#personlogo","inLanguage":"en-GB","url":"https://secure.gravatar.com/avatar/2856a0ce61680c87f321102dc2acbe89?s=96&d=mm&r=g","caption":"peppe8o"},"logo":{"@id":"https://peppe8o.com/#personlogo"},"sameAs":[]},{"@type":"WebSite","@id":"https://peppe8o.com/#website","url":"https://peppe8o.com/","name":"peppe8o","inLanguage":"en-GB","description":"Simple made easy","publisher":{"@id":"https://peppe8o.com/#/schema/person/758b44898a41588ed5cfe04a6a583b13"},"potentialAction":[{"@type":"SearchAction","target":"https://peppe8o.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://peppe8o.com/emulating-mvs-mainframe-on-raspberry-pi/#primaryimage","inLanguage":"en-GB","url":"https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-emulation-featured-image.jpg","width":562,"height":453,"caption":"RPI MVS emulation featured image"},{"@type":"WebPage","@id":"https://peppe8o.com/emulating-mvs-mainframe-on-raspberry-pi/#webpage","url":"https://peppe8o.com/emulating-mvs-mainframe-on-raspberry-pi/","name":"Emulating MVS Mainframe on Raspberry PI - peppe8o","isPartOf":{"@id":"https://peppe8o.com/#website"},"inLanguage":"en-GB","primaryImageOfPage":{"@id":"https://peppe8o.com/emulating-mvs-mainframe-on-raspberry-pi/#primaryimage"},"datePublished":"2020-02-28T18:40:57+00:00","dateModified":"2020-02-28T18:45:19+00:00","description":"Emulating Mainframe MVS on Raspberry PI to reproduce a vintage enterprise system in your credit card sized computer. Create your first dataset with TSO.","potentialAction":[{"@type":"ReadAction","target":["https://peppe8o.com/emulating-mvs-mainframe-on-raspberry-pi/"]}]},{"@type":"Article","@id":"https://peppe8o.com/emulating-mvs-mainframe-on-raspberry-pi/#article","isPartOf":{"@id":"https://peppe8o.com/emulating-mvs-mainframe-on-raspberry-pi/#webpage"},"author":{"@id":"https://peppe8o.com/#/schema/person/758b44898a41588ed5cfe04a6a583b13"},"headline":"Emulating MVS Mainframe on Raspberry PI","datePublished":"2020-02-28T18:40:57+00:00","dateModified":"2020-02-28T18:45:19+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://peppe8o.com/emulating-mvs-mainframe-on-raspberry-pi/#webpage"},"publisher":{"@id":"https://peppe8o.com/#/schema/person/758b44898a41588ed5cfe04a6a583b13"},"image":{"@id":"https://peppe8o.com/emulating-mvs-mainframe-on-raspberry-pi/#primaryimage"},"keywords":"hercules,mainframe,MVS,raspberry pi,raspbian buster lite,TK4,TSO","articleSection":"raspberry","inLanguage":"en-GB","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://peppe8o.com/emulating-mvs-mainframe-on-raspberry-pi/#respond"]}]}]}</script>
<link rel="amphtml" href="https://peppe8o.com/emulating-mvs-mainframe-on-raspberry-pi/amp/" /><meta name="generator" content="AMP for WP 1.0.35"/><link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="peppe8o &raquo; Feed" href="https://peppe8o.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="peppe8o &raquo; Comments Feed" href="https://peppe8o.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="peppe8o &raquo; Emulating MVS Mainframe on Raspberry PI Comments Feed" href="https://peppe8o.com/emulating-mvs-mainframe-on-raspberry-pi/feed/" />
<script type="text/javascript" data-cfasync="false">var mi_version='7.10.4';var mi_track_user=true;var mi_no_track_reason='';var disableStr='ga-disable-UA-137814626-1';function __gaTrackerIsOptedOut(){return document.cookie.indexOf(disableStr+'=true')>-1;}
if(__gaTrackerIsOptedOut()){window[disableStr]=true;}
function __gaTrackerOptout(){document.cookie=disableStr+'=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';window[disableStr]=true;}
if(mi_track_user){(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');__gaTracker('create','UA-137814626-1','auto');__gaTracker('set','forceSSL',true);__gaTracker('require','displayfeatures');__gaTracker('send','pageview');}else{console.log("");(function(){var noopfn=function(){return null;};var noopnullfn=function(){return null;};var Tracker=function(){return null;};var p=Tracker.prototype;p.get=noopfn;p.set=noopfn;p.send=noopfn;var __gaTracker=function(){var len=arguments.length;if(len===0){return;}
var f=arguments[len-1];if(typeof f!=='object'||f===null||typeof f.hitCallback!=='function'){console.log('Not running function __gaTracker('+arguments[0]+" ....) because you are not being tracked. "+mi_no_track_reason);return;}
try{f.hitCallback();}catch(ex){}};__gaTracker.create=function(){return new Tracker();};__gaTracker.getByName=noopnullfn;__gaTracker.getAll=function(){return[];};__gaTracker.remove=noopfn;window['__gaTracker']=__gaTracker;})();}</script>
<style media="all">@font-face{font-display:swap;font-family:'Raleway';font-style:normal;font-weight:400;font-display:swap;src:local('Raleway'),local('Raleway-Regular'),url('https://peppe8o.com/wp-content/themes/donovan/assets/css/../fonts/raleway-v12-latin-ext_latin-regular.woff2') format('woff2'),url('https://peppe8o.com/wp-content/themes/donovan/assets/css/../fonts/raleway-v12-latin-ext_latin-regular.woff') format('woff');}@font-face{font-display:swap;font-family:'Raleway';font-style:italic;font-weight:400;font-display:swap;src:local('Raleway Italic'),local('Raleway-Italic'),url('https://peppe8o.com/wp-content/themes/donovan/assets/css/../fonts/raleway-v12-latin-ext_latin-italic.woff2') format('woff2'),url('https://peppe8o.com/wp-content/themes/donovan/assets/css/../fonts/raleway-v12-latin-ext_latin-italic.woff') format('woff');}@font-face{font-display:swap;font-family:'Raleway';font-style:normal;font-weight:700;font-display:swap;src:local('Raleway Bold'),local('Raleway-Bold'),url('https://peppe8o.com/wp-content/themes/donovan/assets/css/../fonts/raleway-v12-latin-ext_latin-700.woff2') format('woff2'),url('https://peppe8o.com/wp-content/themes/donovan/assets/css/../fonts/raleway-v12-latin-ext_latin-700.woff') format('woff');}@font-face{font-display:swap;font-family:'Raleway';font-style:italic;font-weight:700;font-display:swap;src:local('Raleway Bold Italic'),local('Raleway-BoldItalic'),url('https://peppe8o.com/wp-content/themes/donovan/assets/css/../fonts/raleway-v12-latin-ext_latin-700italic.woff2') format('woff2'),url('https://peppe8o.com/wp-content/themes/donovan/assets/css/../fonts/raleway-v12-latin-ext_latin-700italic.woff') format('woff');}@font-face{font-display:swap;font-family:'Quicksand';font-style:normal;font-weight:400;font-display:swap;src:local('Quicksand Regular'),local('Quicksand-Regular'),url('https://peppe8o.com/wp-content/themes/donovan/assets/css/../fonts/quicksand-v7-latin-ext_latin-regular.woff2') format('woff2'),url('https://peppe8o.com/wp-content/themes/donovan/assets/css/../fonts/quicksand-v7-latin-ext_latin-regular.woff') format('woff');}@font-face{font-display:swap;font-family:'Quicksand';font-style:normal;font-weight:700;font-display:swap;src:local('Quicksand Bold'),local('Quicksand-Bold'),url('https://peppe8o.com/wp-content/themes/donovan/assets/css/../fonts/quicksand-v7-latin-ext_latin-700.woff2') format('woff2'),url('https://peppe8o.com/wp-content/themes/donovan/assets/css/../fonts/quicksand-v7-latin-ext_latin-700.woff') format('woff');}</style>
<style media="all" data-phast-original-src="https://peppe8o.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2" data-phast-params='{"ref":"WQTSMNz8-w8"}'>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</style>
<style media="all" data-phast-original-src="https://peppe8o.com/wp-content/uploads/advgb/custom_styles.css?ver=5.3.2" data-phast-params='{"ref":"Iw9HYMIpm1c"}'></style>
<style media="all" data-phast-original-src="https://peppe8o.com/wp-includes/css/dashicons.min.css?ver=5.3.2" data-phast-params='{"ref":"ZWKMvIPghac"}'>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</style>
<style media="all" data-phast-original-src="https://peppe8o.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-public.css?ver=1.8.5" data-phast-params='{"ref":"dw7-O12B2OU"}'>#cookie-law-info-bar{font-size:12pt;margin:0 auto;padding:13px 10px;position:absolute;text-align:center;box-sizing:border-box;width:100%;z-index:9999;box-shadow:rgba(0,0,0,.5) 0px 5px 50px;display:none;left:0px;font-weight:300;}#cookie-law-info-again{font-size:10pt;margin:0;padding:5px 10px;text-align:center;z-index:9999;cursor:pointer;box-shadow:#161616 2px 2px 5px 2px;}#cookie-law-info-bar span{vertical-align:middle;}.cli-plugin-button,.cli-plugin-button:visited{display:inline-block;padding:10px 16px 10px;color:#fff;text-decoration:none;position:relative;cursor:pointer;margin-left:0px;text-decoration:none;}.cli-plugin-main-link{margin-left:0px;font-weight:550;text-decoration:underline;}.cli-plugin-button:hover{background-color:#111;color:#fff;text-decoration:none;}.cli-plugin-button,.cli-plugin-button:visited,.medium.cli-plugin-button,.medium.cli-plugin-button:visited{font-size:14px;font-weight:500;line-height:1;}.cli-plugin-button{margin-top:5px;}.cli-bar-popup{-moz-background-clip:padding;-webkit-background-clip:padding;background-clip:padding-box;-webkit-border-radius:30px;-moz-border-radius:30px;border-radius:30px;padding:20px;}</style>
<style media="all" data-phast-original-src="https://peppe8o.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-gdpr.css?ver=1.8.5" data-phast-params='{"ref":"63Pb-JFzjcQ"}'>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</style>
<style media="all" data-phast-original-src="https://peppe8o.com/wp-content/themes/donovan/style.css?ver=1.4.5" data-phast-params='{"ref":"aNyIMCs4G8A"}'>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</style>
<style media="all" data-phast-original-src="https://peppe8o.com/wp-content/plugins/newsletter/style.css?ver=6.5.7" data-phast-params='{"ref":"iKd5Zntud-4"}'>.tnp-subscription input[type=text],.tnp-subscription input[type=email],.tnp-subscription input[type=submit],.tnp-subscription select{width:100%;height:50px;padding:10px;display:block;border:1px;border-color:#ddd;background-color:#f4f4f4;background-image:none;text-shadow:none;color:#444;font-size:14px;line-height:20px;margin:0;line-height:normal;box-sizing:border-box;}.tnp-subscription input[type=checkbox],.tnp-widget input[type=radio]{max-width:20px;display:inline-block;}@media all and (max-width:480px){.tnp-subscription input[type=submit]{width:100%;}}.tnp-profile form .tnp-field input[type=text],.tnp-profile form .tnp-field input[type=email],.tnp-profile form .tnp-field input[type=submit],.tnp-profile form .tnp-field textarea,.tnp-profile form .tnp-field select{padding:10px;display:block;border:1px;border-color:#ddd;background-color:#f4f4f4;background-image:none;text-shadow:none;color:#444;font-size:14px;margin:0;line-height:normal;box-sizing:border-box;border-radius:0;height:auto;float:none;}.tnp-profile form input[type=checkbox],.tnp-profile input[type=radio]{max-width:20px;display:inline-block;}.tnp-profile form .tnp-field input[type=submit]{background-color:#444;color:#fff;width:auto;height:auto;margin:0;}@media all and (max-width:480px){.tnp-profile input[type=submit]{width:100%;margin:0;}}.tnp-widget{width:100%;display:block;box-sizing:border-box;}.tnp-widget .tnp-field{margin-bottom:10px;border:0;padding:0;}.tnp-widget label{display:block;color:inherit;font-size:14px;}.tnp-widget input[type=text],.tnp-widget input[type=email],.tnp-widget input[type=submit],.tnp-widget select{width:100%;padding:10px;display:block;border:1px solid #ddd;border-color:#ddd;background-color:#f4f4f4;background-image:none;text-shadow:none;color:#444;font-size:14px;line-height:normal;box-sizing:border-box;height:auto;}.tnp-widget input[type=checkbox],.tnp-widget input[type=radio]{width:auto;display:inline-block;}.tnp-widget select option{margin-right:10px;}.tnp-widget input.tnp-submit{background-color:#444;background-image:none;text-shadow:none;color:#fff;margin:0;}.tnp-field input[type="submit"]{position:inherit;}.tnp-field label{}.tnp-comments input[type=checkbox]{display:inline-block;width:auto!important;}</style>
<style media="all" data-phast-original-src="https://peppe8o.com/wp-content/plugins/super-socializer/css/front.css?ver=7.12.40" data-phast-params='{"ref":"MUJ1Wr6Rva4"}'>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</style>
<style media="all" data-phast-original-src="https://peppe8o.com/wp-content/plugins/super-socializer/css/share-svg.css?ver=7.12.40" data-phast-params='{"ref":"wfXuELVloEs"}'>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</style>
<style media="all" data-phast-original-src="https://peppe8o.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.10" data-phast-params='{"ref":"iFT4EFPGp2w"}'>@font-face{font-display:swap;font-family:TablePress;src:url(https://peppe8o.com/wp-content/plugins/tablepress/css/tablepress.eot);src:url(tablepress.eot#ie) format('embedded-opentype'),url(data:application/x-font-woff;base64,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) format('woff'),url(https://peppe8o.com/wp-content/plugins/tablepress/css/tablepress.ttf) format('truetype'),url(https://peppe8o.com/wp-content/plugins/tablepress/css/tablepress.svg#TablePress) format('svg');font-weight:400;font-style:normal}</style>
<style media="all">.lazy-hidden,.entry img.lazy-hidden,img.thumbnail.lazy-hidden{background-color:#ffffff;background-image:url('https://peppe8o.com/wp-content/plugins/a3-lazy-load/assets/css/loading.gif');background-repeat:no-repeat;background-position:50% 50%;}figure.wp-block-image img.lazy-hidden{min-width:150px;}picture source[type="image/webp"]{display:block;}</style>
<style media="all">.clear{clear:both}.nobr{white-space:nowrap}.lazy-hidden,.entry img.lazy-hidden,img.thumbnail.lazy-hidden{background-color:#fff}</style>
<script data-phast-original-type="text/javascript" type="text/phast">var monsterinsights_frontend={"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/peppe8o.com","hash_tracking":"false"};</script>
<script data-phast-original-src="https://peppe8o.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.10.4" data-phast-params='{"ref":"zTU3mdT1z6M"}' data-phast-original-type="text/javascript" type="text/phast"></script>
<script data-phast-original-src="https://peppe8o.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp" data-phast-params='{"ref":"rvArKKp7Vs4"}' data-phast-original-type="text/javascript" type="text/phast"></script>
<script data-phast-original-src="https://peppe8o.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1" data-phast-params='{"ref":"rEzM5OmYFlA"}' data-phast-original-type="text/javascript" type="text/phast"></script>
<script data-phast-original-type="text/javascript" type="text/phast">var Cli_Data={"nn_cookie_ids":[],"cookielist":[]};var log_object={"ajax_url":"https:\/\/peppe8o.com\/wp-admin\/admin-ajax.php"};</script>
<script data-phast-original-src="https://peppe8o.com/wp-content/plugins/cookie-law-info/public/js/cookie-law-info-public.js?ver=1.8.5" data-phast-params='{"ref":"SvBsEGIVExI"}' data-phast-original-type="text/javascript" type="text/phast"></script>
<script data-phast-original-type="text/javascript" type="text/phast">var donovan_menu_title="<svg class=\"icon icon-menu\" aria-hidden=\"true\" role=\"img\"> <use xlink:href=\"https:\/\/peppe8o.com\/wp-content\/themes\/donovan\/assets\/icons\/genericons-neue.svg#menu\"><\/use> <\/svg>Menu";</script>
<script data-phast-original-src="https://peppe8o.com/wp-content/themes/donovan/assets/js/navigation.js?ver=20171005" data-phast-params='{"ref":"WOVX5REoj7E"}' data-phast-original-type="text/javascript" type="text/phast"></script>
<script data-phast-original-src="https://peppe8o.com/wp-content/themes/donovan/assets/js/svgxuse.min.js?ver=1.2.4" data-phast-params='{"ref":"ALdX_wZRLfg"}' data-phast-original-type="text/javascript" type="text/phast"></script>
<link rel='https://api.w.org/' href='https://peppe8o.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://peppe8o.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://peppe8o.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://peppe8o.com/?p=1509' />
<link rel="alternate" type="application/json+oembed" href="https://peppe8o.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fpeppe8o.com%2Femulating-mvs-mainframe-on-raspberry-pi%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://peppe8o.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fpeppe8o.com%2Femulating-mvs-mainframe-on-raspberry-pi%2F&#038;format=xml" />
<style>a.al[href*="amazon"]{background:url(https://peppe8o.com/wp-content/uploads/2020/02/amazon-icon-20px.png) no-repeat left center;background-position:6px 0;border:1px solid black;background-color:#FF9900;padding:0px 5px 0px 30px;-webkit-border-radius:8px;-moz-border-radius:8px;border-radius:8px;}</style>
<script>console.log("%cOptimized with %cPhastPress%c %s\nhttps:\/\/wordpress.org\/plugins\/phastpress\/","font-family:helvetica,sans-serif","font-family:helvetica,sans-serif;font-weight:bold","font-family:helvetica,sans-serif","1.39")</script><link rel="pingback" href="https://peppe8o.com/xmlrpc.php">
<script data-phast-original-type="text/javascript" type="text/phast">var cli_flush_cache=1;</script>
<link rel="icon" href="https://peppe8o.com/wp-content/uploads/2018/11/cropped-Logo2D-e1553897977415-32x32.png" sizes="32x32" />
<link rel="icon" href="https://peppe8o.com/wp-content/uploads/2018/11/cropped-Logo2D-e1553897977415-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://peppe8o.com/wp-content/uploads/2018/11/cropped-Logo2D-e1553897977415-180x180.png" />
<meta name="msapplication-TileImage" content="https://peppe8o.com/wp-content/uploads/2018/11/cropped-Logo2D-e1553897977415-270x270.png" />
<style>body,#content,.entry-content,.post-content,.page-content,.post-excerpt,.entry-summary,.entry-excerpt,.widget-area,.widget,.sidebar,#sidebar,footer,.footer,#footer,.site-footer{font-family:Calibri,Candara,Segoe,Segoe UI,Optima,Arial,sans-serif;;}#site-title,.site-title,#site-title a,.site-title a,.entry-title,.entry-title a,h1,h2,h3,h4,h5,h6,.widget-title{font-family:Calibri,Candara,Segoe,Segoe UI,Optima,Arial,sans-serif;;}button,input,select,textarea{font-family:Calibri,Candara,Segoe,Segoe UI,Optima,Arial,sans-serif;;}#site-title,.site-title,#site-title a,.site-title a,#logo,#logo a,.logo,.logo a{font-family:Calibri,Candara,Segoe,Segoe UI,Optima,Arial,sans-serif;;}#site-description,.site-description{font-family:Calibri,Candara,Segoe,Segoe UI,Optima,Arial,sans-serif;;}.menu,.page_item a,.menu-item a{font-family:Calibri,Candara,Segoe,Segoe UI,Optima,Arial,sans-serif;;}.entry-content,.entry-content p,.post-content,.page-content,.post-excerpt,.entry-summary,.entry-excerpt,.excerpt,.excerpt p{font-family:Calibri,Candara,Segoe,Segoe UI,Optima,Arial,sans-serif;;}.entry-title,.entry-title a,.post-title,.post-title a,.page-title,.entry-content h1,#content h1{font-family:Calibri,Candara,Segoe,Segoe UI,Optima,Arial,sans-serif;;}.entry-content h2,.post-content h2,.page-content h2,#content h2{font-family:Calibri,Candara,Segoe,Segoe UI,Optima,Arial,sans-serif;;}.entry-content h3,.post-content h3,.page-content h3,#content h3{font-family:Calibri,Candara,Segoe,Segoe UI,Optima,Arial,sans-serif;;}.entry-content h5,.post-content h5,.page-content h5,#content h5{font-family:Calibri,Candara,Segoe,Segoe UI,Optima,Arial,sans-serif;;}.entry-content h6,.post-content h6,.page-content h6,#content h6{font-family:Calibri,Candara,Segoe,Segoe UI,Optima,Arial,sans-serif;;}.widget-title,.widget-area h1,.widget-area h2,.widget-area h3,.widget-area h4,.widgets-area h5,.widget-area h6{font-family:Calibri,Candara,Segoe,Segoe UI,Optima,Arial,sans-serif;;}.widget-area,.widget,.sidebar,#sidebar{font-family:Calibri,Candara,Segoe,Segoe UI,Optima,Arial,sans-serif;;}footer h1,footer h2,footer h3,footer h4,footer h5,footer h6,.footer h1,.footer h2,.footer h3,.footer h4,.footer h5,.footer h6 #footer h1,#footer h2,#footer h3,#footer h4,#footer h5,#footer h6{font-family:Calibri,Candara,Segoe,Segoe UI,Optima,Arial,sans-serif;;}footer,#footer,.footer,.site-footer{font-family:Calibri,Candara,Segoe,Segoe UI,Optima,Arial,sans-serif;;}</style>
<style>.ai-viewports{--ai:1;}.ai-viewport-3{display:none !important;}.ai-viewport-2{display:none !important;}.ai-viewport-1{display:inherit !important;}.ai-viewport-0{display:none !important;}@media (min-width:768px) and (max-width:979px){.ai-viewport-1{display:none !important;}.ai-viewport-2{display:inherit !important;}}@media (max-width:767px){.ai-viewport-1{display:none !important;}.ai-viewport-3{display:inherit !important;}}</style>
</head>
<body class="post-template-default single single-post postid-1509 single-format-standard wp-embed-responsive blog-grid-layout author-hidden categories-hidden tags-hidden">
<div id="page" class="site">
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header clearfix" role="banner">
<div class="header-main container clearfix">
<div id="logo" class="site-branding clearfix">
<p class="site-title"><a href="https://peppe8o.com/" rel="home">peppe8o</a></p>
<p class="site-description">Simple made easy</p>
</div>
</div>
<div id="main-navigation-wrap" class="primary-navigation-wrap">
<div id="main-navigation-container" class="primary-navigation-container container">
<nav id="main-navigation" class="primary-navigation navigation clearfix" role="navigation">
<ul id="menu-primary" class="main-navigation-menu"><li id="menu-item-225" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-225"><a title="
" href="/">Home</a></li>
<li id="menu-item-424" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-424"><a title="
" href="https://peppe8o.com/info/">Info</a></li>
<li id="menu-item-1112" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-has-children menu-item-1112"><a href="https://peppe8o.com/privacy-policy/">Privacy Policy<span class="sub-menu-icon"><svg class="icon icon-expand" aria-hidden="true" role="img"> <use xlink:href="https://peppe8o.com/wp-content/themes/donovan/assets/icons/genericons-neue.svg#expand"></use> </svg></span></a>
<ul class="sub-menu">
<li id="menu-item-1118" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1118"><a href="https://peppe8o.com/privacy-tools/">Privacy Tools</a></li>
</ul>
</li>
</ul> </nav>
</div>
</div>
</header>
<div id="content" class="site-content container">
<div id="primary" class="content-area">
<main id="main" class="site-main">
<div class='code-block code-block-2' style='margin: 8px 0; clear: both;'>
<i>Some links in this post may be affiliate links. We may get paid if you buy something or take an action after clicking one of these, but without addictional costs for you compared to direct buying.</i></div>
<article id="post-1509" class="post-1509 post type-post status-publish format-standard has-post-thumbnail hentry category-raspberry tag-hercules tag-mainframe tag-mvs tag-raspberry-pi tag-raspbian-buster-lite tag-tk4 tag-tso">
<div class="post-image">
<img width="562" height="453" src="//peppe8o.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-emulation-featured-image.jpg" class="lazy lazy-hidden attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="RPI MVS emulation featured image" srcset="" data-srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-emulation-featured-image.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-emulation-featured-image-300x242.jpg 300w" sizes="(max-width: 562px) 100vw, 562px" /><noscript><img width="562" height="453" src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-emulation-featured-image.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="RPI MVS emulation featured image" srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-emulation-featured-image.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-emulation-featured-image-300x242.jpg 300w" sizes="(max-width: 562px) 100vw, 562px" /></noscript> </div>
<div class="post-content">
<header class="entry-header">
<h1 class="entry-title">Emulating MVS Mainframe on Raspberry PI</h1>
<div class="entry-meta post-details"><span class="posted-on meta-date">Posted on <a href="https://peppe8o.com/emulating-mvs-mainframe-on-raspberry-pi/" rel="bookmark"><time class="entry-date published" datetime="2020-02-28T18:40:57+00:00">28th February 2020</time><time class="updated" datetime="2020-02-28T18:45:19+00:00">28th February 2020</time></a></span><span class="posted-by meta-author"> by <span class="author vcard"><a class="url fn n" href="https://peppe8o.com/author/peppe8o/" title="View all posts by peppe8o" rel="author">peppe8o</a></span></span></div>
</header>
<div class="entry-content clearfix">
<div class='code-block code-block-4' style='margin: 8px 0; clear: both;'>
<hr>
Before start reading: please consider, if this article is useful to you or if you just appreciate my work on it, to support me just sharing this article with your friends by your favourite Social Network. This would be a really appreciated help.
Have a nice reading!
<hr>
</div>
<p class="post-last-modified">Last Updated on <time class="post-last-modified-td">28th February 2020</time></p>
<p><a rel="noreferrer noopener" aria-label="Wikipedia Mainframe Computer (opens in a new tab)" href="https://en.wikipedia.org/wiki/Mainframe_computer" target="_blank">Wikipedia Mainframe Computer</a> page defines Mainframe as following:</p>
<blockquote class="wp-block-quote"><p><em>Mainframe computers or mainframes (colloquially referred to as &#8220;big iron&#8221;) are computers used primarily by large organizations for critical applications; bulk data processing, such as census, industry and consumer statistics, enterprise resource planning; and transaction processing. They are larger and have more processing power than some other classes of computers: minicomputers, servers, workstations, and personal computers.</em></p></blockquote>
<p>Mainframes are focused on some key factors, vital for critical businesses:</p>
<ul><li>high availability</li><li>security</li><li>high I/O volumes</li><li>reliability for transaction processing </li></ul>
<p>Even if they are currently considered as an outdated technology (compared to modern virtual machines / container technology), they are still deep-rooted in modern datacenters, expecially for banks, stock exchange, etc</p>
<p>In this article I&#8217;m going to show you how to run a Mainframe MVS (Multiple Virtual Storage) inside &#8230; a Raspberry PI!</p>
<h2>What We Need</h2>
<div class="wp-block-image"><figure class="alignright size-large"><a href="https://www.amazon.com/gp/product/B07TD42S27/ref=as_li_tl?ie=UTF8&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B07TD42S27&amp;linkCode=as2&amp;tag=peppe8o0b-20&amp;linkId=5c1d74ca0df9ca860f9547cbd214294f" target="_blank" rel="noreferrer noopener"><img src="//peppe8o.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://peppe8o.com/wp-content/uploads/2019/09/Raspberry-PI-4-model-B-image.jpg" alt="Raspberry PI 4 model B image" class="lazy lazy-hidden wp-image-1141"/><noscript><img src="https://peppe8o.com/wp-content/uploads/2019/09/Raspberry-PI-4-model-B-image.jpg" alt="Raspberry PI 4 model B image" class="wp-image-1141"/></noscript></a><figcaption>Raspberry PI 4 model B image</figcaption></figure></div>
<p>As usual, I suggest adding from now to your favourite ecommerce shopping chart all needed hardware, so that at the end you will be able to evaluate overall costs and decide if continuing with the project or removing them from shopping chart. So, hardware will be only: </p>
<ul><li><a class="al" rel="noopener noreferrer" href="https://www.amazon.com/gp/product/B07TD43PDZ/ref=as_li_tl?ie=UTF8&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B07TD43PDZ&amp;linkCode=as2&amp;tag=peppe8o0b-20&amp;linkId=f0ca0204e4f5168e9259781f635c9d0a" target="_blank">Raspberry PI</a> (including proper <a class="al" rel="noreferrer noopener" aria-label="power supply (opens in a new tab)" href="https://www.amazon.com/gp/product/B01N336XEU/ref=as_li_tl?ie=UTF8&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B01N336XEU&amp;linkCode=as2&amp;tag=peppe8o0b-20&amp;linkId=10921394efb918f8d61a6d093e84fef3" target="_blank">power supply</a> or using a smartphone micro usb charger with at least 3A)</li><li><a class="al" rel="noreferrer noopener" aria-label="micro SD card (opens in a new tab)" href="https://www.amazon.com/gp/product/9966624805/ref=as_li_tl?ie=UTF8&amp;camp=1789&amp;creative=9325&amp;creativeASIN=9966624805&amp;linkCode=as2&amp;tag=peppe8o0b-20&amp;linkId=4c2b4a90eefd9c95707b0d5b3e208ffb" target="_blank">micro SD card</a> (at least 16 GB, at least class 10)</li></ul>
<h2>Step-by-Step Guide</h2>
<p>This guide will use an amazing MVS package available from <a href="http://wotho.ethz.ch/tk4-/">wotho.ethz.ch</a>, which includes also a User Manual explaining how to use this MVS emulation.</p>
<h3>Installing OS</h3>
<p>Install Raspberry PI OS using <a href="https://peppe8o.com/install-raspbian-buster-lite-in-your-raspberry-pi/">Install Raspbian Buster Lite in your Raspberry PI</a> guide.</p>
<h3>Install TK4 MVS Emulation</h3>
<p>We&#8217;ll download and unzip tk4 package inside a new folder from where our system will load. From Raspberry PI type the following commands:</p>
<pre class="wp-block-preformatted">mkdir mvs
cd mvs
wget http://wotho.ethz.ch/tk4-/tk4-_v1.00_current.zip
unzip tk4-_v1.00_current.zip</pre>
<p>Now your MVS emulation is ready to be started. </p>
<p>Basic configuration doesn&#8217;t need any change and runs in unattended mode with the simple command:</p>
<pre class="wp-block-preformatted">./mvs</pre>
<p>This launches an unattended startup. At the end of load procedure, you will see the following screen:</p>
<figure class="wp-block-image size-large"><img src="//peppe8o.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://peppe8o.com/wp-content/uploads/2020/02/MVS-startup.jpg" alt="MVS startup" class="lazy lazy-hidden wp-image-1511" srcset="" data-srcset="https://peppe8o.com/wp-content/uploads/2020/02/MVS-startup.jpg 826w, https://peppe8o.com/wp-content/uploads/2020/02/MVS-startup-300x151.jpg 300w, https://peppe8o.com/wp-content/uploads/2020/02/MVS-startup-768x387.jpg 768w" sizes="(max-width: 826px) 100vw, 826px" /><noscript><img src="https://peppe8o.com/wp-content/uploads/2020/02/MVS-startup.jpg" alt="MVS startup" class="wp-image-1511" srcset="https://peppe8o.com/wp-content/uploads/2020/02/MVS-startup.jpg 826w, https://peppe8o.com/wp-content/uploads/2020/02/MVS-startup-300x151.jpg 300w, https://peppe8o.com/wp-content/uploads/2020/02/MVS-startup-768x387.jpg 768w" sizes="(max-width: 826px) 100vw, 826px" /></noscript></figure>
<h2>Connect To MVS</h2>
<p>To login in your MVS, you will need a terminal capable to start an x3270 session. </p>
<p>For Windows PC, a free terminal can be downloaded from <a href="https://sourceforge.net/projects/x3270/">https://sourceforge.net/projects/x3270/</a>. Another alternative is the good Mocha TN3270 available with 30 days trial as Chrome Extension from <a rel="noreferrer noopener" aria-label="Mocha Chrome store (opens in a new tab)" href="https://chrome.google.com/webstore/detail/mocha-tn3270/lkjoniahmlncloecohelnaipbphjicbh?utm_source=chrome-app-launcher-info-dialog" target="_blank">Mocha Chrome store</a>.</p>
<p>In both case, set your connection parameters with:</p>
<ul><li>Host: IP address of your <a href="https://www.amazon.com/gp/product/B07TD42S27/ref=as_li_tl?ie=UTF8&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B07TD42S27&amp;linkCode=as2&amp;tag=peppe8o0b-20&amp;linkId=5c1d74ca0df9ca860f9547cbd214294f" target="_blank" rel="noreferrer noopener" aria-label="Raspberry PI (opens in a new tab)">Raspberry PI</a></li><li>port: 3270</li></ul>
<p>Once connected, a logon is required:</p>
<figure class="wp-block-image size-large"><img src="//peppe8o.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-logon-prompt.jpg" alt="RPI MVS logon prompt" class="lazy lazy-hidden wp-image-1516" srcset="" data-srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-logon-prompt.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-logon-prompt-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /><noscript><img src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-logon-prompt.jpg" alt="RPI MVS logon prompt" class="wp-image-1516" srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-logon-prompt.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-logon-prompt-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /></noscript></figure>
<p>Use one of default users. For example:</p>
<ul><li>user: HERC01</li><li>password: CUL8TR</li></ul>
<p>Once connected, with 2 RETURN pressing you will go to TSO home page:</p>
<figure class="wp-block-image size-large"><img src="//peppe8o.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-TSO-home.jpg" alt="RPI MVS TSO home" class="lazy lazy-hidden wp-image-1517" srcset="" data-srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-TSO-home.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-TSO-home-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /><noscript><img src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-TSO-home.jpg" alt="RPI MVS TSO home" class="wp-image-1517" srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-TSO-home.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-TSO-home-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /></noscript></figure>
<h2>Very First Exercise With TK4 TSO: Create a Simple Dataset</h2>
<h3>Terminal Emulator Screen</h3>
<p>Before all, a few description of main parts in Terminal Emulator. It is composed by 3 main parts:</p>
<figure class="wp-block-image size-large"><img src="//peppe8o.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-x3270-emulator-parts.jpg" alt="RPI MVS x3270 emulator parts" class="lazy lazy-hidden wp-image-1518" srcset="" data-srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-x3270-emulator-parts.jpg 886w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-x3270-emulator-parts-300x198.jpg 300w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-x3270-emulator-parts-768x506.jpg 768w" sizes="(max-width: 886px) 100vw, 886px" /><noscript><img src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-x3270-emulator-parts.jpg" alt="RPI MVS x3270 emulator parts" class="wp-image-1518" srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-x3270-emulator-parts.jpg 886w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-x3270-emulator-parts-300x198.jpg 300w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-x3270-emulator-parts-768x506.jpg 768w" sizes="(max-width: 886px) 100vw, 886px" /></noscript></figure>
<p>Emulation screen usually gives in top section an Option filed where to select desired option to execute (Return to execute in some terminal emulators, or CTRL in some other terminal emulator). Options are listed in following section, each line reporting option number and related action.</p>
<p>Function keys (F1 to F12) have an important role in terminal, because each one is a shortcut to a specific function. For example, the most common and most used is F3, to go back in previous screen.</p>
<h3> What Is a Dataset</h3>
<p>A data set or dataset (<a rel="noreferrer noopener" aria-label="refer to Wikipedia for Data set description (opens in a new tab)" href="https://en.wikipedia.org/wiki/Data_set_(IBM_mainframe)#:~:text=In%20the%20context%20of%20IBM,file%20having%20a%20record%20organization.&amp;text=Within%20a%20running%20program%20they,for%20example%20using%20access%20methods." target="_blank">refer to Wikipedia for Data set description</a>) is a file with a record organization. It can be associated to a mix of more common Windows directories and files or Linux folders and files.</p>
<p>To create the first dataset (which will be a simple text dataset), from TSO home page with option 2 select the RPF productivity tool. With the word &#8220;select&#8221;, in this paragraph, I will intend to write option number and press Return (or CTRL where it is configured as option confirmation):</p>
<figure class="wp-block-image size-large"><img src="//peppe8o.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-1.jpg" alt="RPI MVS create dataset (1)" class="lazy lazy-hidden wp-image-1519" srcset="" data-srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-1.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-1-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /><noscript><img src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-1.jpg" alt="RPI MVS create dataset (1)" class="wp-image-1519" srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-1.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-1-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /></noscript></figure>
<p>Select 3 to use RPF utility:</p>
<figure class="wp-block-image size-large"><img src="//peppe8o.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-2.jpg" alt="RPI MVS create dataset (2)" class="lazy lazy-hidden wp-image-1520" srcset="" data-srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-2.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-2-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /><noscript><img src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-2.jpg" alt="RPI MVS create dataset (2)" class="wp-image-1520" srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-2.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-2-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /></noscript></figure>
<p>Select otion 2 to Create a new dataset:</p>
<figure class="wp-block-image size-large"><img src="//peppe8o.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-3.jpg" alt="RPI MVS create dataset (3)" class="lazy lazy-hidden wp-image-1521" srcset="" data-srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-3.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-3-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /><noscript><img src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-3.jpg" alt="RPI MVS create dataset (3)" class="wp-image-1521" srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-3.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-3-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /></noscript></figure>
<p>Here we&#8217;ll configure dataset naming (and logical position) modifying parameters circled in following picture. All other parameters can be left with default values:</p>
<figure class="wp-block-image size-large"><img src="//peppe8o.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-4.jpg" alt="RPI MVS create dataset (4)" class="lazy lazy-hidden wp-image-1522" srcset="" data-srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-4.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-4-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /><noscript><img src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-4.jpg" alt="RPI MVS create dataset (4)" class="wp-image-1522" srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-4.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-4-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /></noscript></figure>
<p>Now select option 1 to allocate (the space) the dataset. The terminal confirms that dataset have been allocated:</p>
<figure class="wp-block-image size-large"><img src="//peppe8o.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-5.jpg" alt="RPI MVS create dataset (5)" class="lazy lazy-hidden wp-image-1523" srcset="" data-srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-5.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-5-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /><noscript><img src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-5.jpg" alt="RPI MVS create dataset (5)" class="wp-image-1523" srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-5.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-5-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /></noscript></figure>
<p>Press F3 to go back in RPF Utility Menu and select option 4 to search available datasets:</p>
<p> </p>
<p></p>
<figure class="wp-block-image size-large"><img src="//peppe8o.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-6.jpg" alt="RPI MVS create dataset (6)" class="lazy lazy-hidden wp-image-1524" srcset="" data-srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-6.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-6-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /><noscript><img src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-6.jpg" alt="RPI MVS create dataset (6)" class="wp-image-1524" srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-6.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-6-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /></noscript></figure>
<p>Edit in search window (ops&#8230; sorry mainframers, I intended label 🙂 ) with the prefix setup in previous step. In my case, &#8220;PEPPE&#8221;:</p>
<figure class="wp-block-image size-large"><img src="//peppe8o.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-7.jpg" alt="RPI MVS create dataset (7)" class="lazy lazy-hidden wp-image-1525" srcset="" data-srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-7.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-7-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /><noscript><img src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-7.jpg" alt="RPI MVS create dataset (7)" class="wp-image-1525" srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-7.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-7-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /></noscript></figure>
<p>And press Return (or CTRL) to list available datasets with the same prefix. In a new environment, it will show the only one datased allocated:</p>
<figure class="wp-block-image size-large"><img src="//peppe8o.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-8.jpg" alt="RPI MVS create dataset (8)" class="lazy lazy-hidden wp-image-1526" srcset="" data-srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-8.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-8-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /><noscript><img src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-8.jpg" alt="RPI MVS create dataset (8)" class="wp-image-1526" srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-8.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-8-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /></noscript></figure>
<p>Now, the most common actions with a dataset are browse (to view their content), edit (to modify their content) or delete (to delete the entire dataset). These actions can be performed by adding the related command letter (b=browse, e=edit, d=delete) on the left of dataset. We&#8217;ll perform and edit to add content inside our dataset. So, add the &#8220;e&#8221; at the left of dataset:</p>
<figure class="wp-block-image size-large"><img src="//peppe8o.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-9.jpg" alt="RPI MVS create dataset (9)" class="lazy lazy-hidden wp-image-1527" srcset="" data-srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-9.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-9-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /><noscript><img src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-9.jpg" alt="RPI MVS create dataset (9)" class="wp-image-1527" srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-9.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-9-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /></noscript></figure>
<p>And press Return (or CTRL). An empty editor screen will appear. Fill with text at your choice and press return to have prompt back in &#8220;Cmd&#8221; area:</p>
<figure class="wp-block-image size-large"><img src="//peppe8o.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-10.jpg" alt="RPI MVS create dataset (10)" class="lazy lazy-hidden wp-image-1528" srcset="" data-srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-10.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-10-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /><noscript><img src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-10.jpg" alt="RPI MVS create dataset (10)" class="wp-image-1528" srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-10.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-10-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /></noscript></figure>
<p>type save near Cmd area and press return.</p>
<figure class="wp-block-image size-large"><img src="//peppe8o.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-11.jpg" alt="RPI MVS create dataset (11)" class="lazy lazy-hidden wp-image-1529" srcset="" data-srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-11.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-11-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /><noscript><img src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-11.jpg" alt="RPI MVS create dataset (11)" class="wp-image-1529" srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-11.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-11-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /></noscript></figure>
<p>Select option 1 and press Return. Terminal will go back in dataset list, also confirming that your dataset have been edited:</p>
<figure class="wp-block-image size-large"><img src="//peppe8o.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-12.jpg" alt="RPI MVS create dataset (12)" class="lazy lazy-hidden wp-image-1530" srcset="" data-srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-12.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-12-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /><noscript><img src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-12.jpg" alt="RPI MVS create dataset (12)" class="wp-image-1530" srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-12.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-create-dataset-12-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /></noscript></figure>
<p>Congratulations, you have created your very first dataset!</p>
<p>Now press F3 as many times to go back in TSO home screen.</p>
<h2>Closing Emulation</h2>
<p>To shutdown, simply exit from TSO (from TSO home screen press F3):</p>
<figure class="wp-block-image size-large"><img src="//peppe8o.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-TSO-exit.jpg" alt="RPI MVS TSO exit" class="lazy lazy-hidden wp-image-1531" srcset="" data-srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-TSO-exit.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-TSO-exit-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /><noscript><img src="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-TSO-exit.jpg" alt="RPI MVS TSO exit" class="wp-image-1531" srcset="https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-TSO-exit.jpg 562w, https://peppe8o.com/wp-content/uploads/2020/02/RPI-MVS-TSO-exit-289x300.jpg 289w" sizes="(max-width: 562px) 100vw, 562px" /></noscript></figure>
<p>and simply type &#8220;shutdown&#8221; and press Return (or CTRL). This will start shutdown procedure.</p>
<p>Enjoy!</p>
<div class='the_champ_sharing_container the_champ_vertical_sharing the_champ_hide_sharing the_champ_bottom_sharing' style='width:44px;left: -10px;top: 100px;-webkit-box-shadow:none;box-shadow:none;' super-socializer-data-href="https://peppe8o.com/emulating-mvs-mainframe-on-raspberry-pi/"><ul class="the_champ_sharing_ul"><li class=""><i style="width:40px;height:40px;margin:0;" alt="Facebook" Title="Facebook" class="theChampSharing theChampFacebookBackground" onclick='theChampPopup("https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fpeppe8o.com%2Femulating-mvs-mainframe-on-raspberry-pi%2F")'><ss style="display:block;" class="theChampSharingSvg theChampFacebookSvg"></ss></i></li><li class=""><i style="width:40px;height:40px;margin:0;" alt="Twitter" Title="Twitter" class="theChampSharing theChampTwitterBackground" onclick='theChampPopup("http://twitter.com/intent/tweet?via=peppecassibba&text=Emulating%20MVS%20Mainframe%20on%20Raspberry%20PI&url=https%3A%2F%2Fpeppe8o.com%2Femulating-mvs-mainframe-on-raspberry-pi%2F")'><ss style="display:block;" class="theChampSharingSvg theChampTwitterSvg"></ss></i></li><li class=""><i style="width:40px;height:40px;margin:0;" alt="Linkedin" Title="Linkedin" class="theChampSharing theChampLinkedinBackground" onclick='theChampPopup("http://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fpeppe8o.com%2Femulating-mvs-mainframe-on-raspberry-pi%2F&title=Emulating%20MVS%20Mainframe%20on%20Raspberry%20PI")'><ss style="display:block;" class="theChampSharingSvg theChampLinkedinSvg"></ss></i></li><li class=""><i style="width:40px;height:40px;margin:0;" alt="Pinterest" Title="Pinterest" class="theChampSharing theChampPinterestBackground" onclick="javascript:void((function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());"><ss style="display:block;" class="theChampSharingSvg theChampPinterestSvg"></ss></i></li><li class=""><i style="width:40px;height:40px;margin:0;" alt="Whatsapp" Title="Whatsapp" class="theChampSharing theChampWhatsappBackground"><a href="https://web.whatsapp.com/send?text=Emulating%20MVS%20Mainframe%20on%20Raspberry%20PI https%3A%2F%2Fpeppe8o.com%2Femulating-mvs-mainframe-on-raspberry-pi%2F" rel="nofollow noopener" target="_blank"><ss style="display:block" class="theChampSharingSvg theChampWhatsappSvg"></ss></a></i></li><li class=""><i style="width:40px;height:40px;margin:0;" alt="Email" Title="Email" class="theChampSharing theChampEmailBackground" onclick="window.open('mailto:?subject=' + decodeURIComponent('Emulating%20MVS%20Mainframe%20on%20Raspberry%20PI' ).replace('&', '%26') + '&body=' + decodeURIComponent('https%3A%2F%2Fpeppe8o.com%2Femulating-mvs-mainframe-on-raspberry-pi%2F' ), '_blank')"><ss style="display:block" class="theChampSharingSvg theChampEmailSvg"></ss></i></li><li class=""><i style="width:40px;height:40px;margin:0;" title="More" alt="More" class="theChampSharing theChampMoreBackground" onclick="theChampMoreSharingPopup(this, 'https://peppe8o.com/emulating-mvs-mainframe-on-raspberry-pi/', 'Emulating%20MVS%20Mainframe%20on%20Raspberry%20PI', '')" ><ss style="display:block" class="theChampSharingSvg theChampMoreSvg"></ss></i></li></ul><div style="clear:both"></div></div><div class='code-block code-block-1 ai-viewport-1' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="amzn-assoc-ad-46d0e781-1fe7-4e72-b18a-f92092e25dde"></div><script type="text/phast" async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&amp;adInstanceId=46d0e781-1fe7-4e72-b18a-f92092e25dde"></script>
</div>
</div>
</div>
<footer class="entry-footer post-details">
<div class="entry-categories"> <svg class="icon icon-category" aria-hidden="true" role="img"> <use xlink:href="https://peppe8o.com/wp-content/themes/donovan/assets/icons/genericons-neue.svg#category"></use> </svg><a href="https://peppe8o.com/category/raspberry/" rel="category tag">raspberry</a></div>
<div class="entry-tags clearfix">
<svg class="icon icon-tag" aria-hidden="true" role="img"> <use xlink:href="https://peppe8o.com/wp-content/themes/donovan/assets/icons/genericons-neue.svg#tag"></use> </svg><a href="https://peppe8o.com/tag/hercules/" rel="tag">hercules</a>, <a href="https://peppe8o.com/tag/mainframe/" rel="tag">mainframe</a>, <a href="https://peppe8o.com/tag/mvs/" rel="tag">MVS</a>, <a href="https://peppe8o.com/tag/raspberry-pi/" rel="tag">raspberry pi</a>, <a href="https://peppe8o.com/tag/raspbian-buster-lite/" rel="tag">raspbian buster lite</a>, <a href="https://peppe8o.com/tag/tk4/" rel="tag">TK4</a>, <a href="https://peppe8o.com/tag/tso/" rel="tag">TSO</a> </div>
</footer>
</article>
<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
<h2 class="screen-reader-text">Post navigation</h2>
<div class="nav-links"><div class="nav-previous"><a href="https://peppe8o.com/using-raspberry-pi-with-dht11-temperature-and-humidity-sensor-and-python/" rel="prev"><span class="nav-link-text">Previous Post</span><h3 class="entry-title">Using Raspberry PI with DHT11 Temperature and Humidity Sensor and Python</h3></a></div><div class="nav-next"><a href="https://peppe8o.com/raspberry-pi-birthday-gift-from-raspbian-foundation/" rel="next"><span class="nav-link-text">Next Post</span><h3 class="entry-title">Raspberry PI birthday gift from Raspbian Foundation</h3></a></div></div>
</nav>
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/emulating-mvs-mainframe-on-raspberry-pi/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://peppe8o.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="gdpr-terms-container">
<label>
<input type="checkbox" required name="gdpr_terms" id="gdpr_terms" value="1" />
I accept the <a href='https://peppe8o.com/privacy-policy/' target='_blank'>Privacy Policy</a> *
</label>
</p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1509' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form> </div>
</div>
</main>
</div>
<section id="secondary" class="sidebar widget-area clearfix" role="complementary">
<section id="search-4" class="widget widget_search">
<form role="search" method="get" class="search-form" action="https://peppe8o.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field"
placeholder="Search &hellip;"
value="" name="s"
title="Search for:" />
</label>
<button type="submit" class="search-submit">
<svg class="icon icon-search" aria-hidden="true" role="img"> <use xlink:href="https://peppe8o.com/wp-content/themes/donovan/assets/icons/genericons-neue.svg#search"></use> </svg> <span class="screen-reader-text">Search</span>
</button>
</form>
</section><section id="newsletterwidget-5" class="widget widget_newsletterwidget"><div class="tnp tnp-widget"><form method="post" action="https://peppe8o.com/?na=s" onsubmit="return newsletter_check(this)">
<input type="hidden" name="nlang" value="">
<input type="hidden" name="nr" value="widget">
<input type='hidden' name='nl[]' value='0'>
<div class="tnp-field tnp-field-firstname"><label>First name or full name</label><input class="tnp-firstname" type="text" name="nn" ></div>
<div class="tnp-field tnp-field-email"><label>Email</label><input class="tnp-email" type="email" name="ne" required></div>
<div class="tnp-field tnp-field-privacy"><label><input type="checkbox" name="ny" required class="tnp-privacy">&nbsp;By continuing, you accept the privacy policy</label></div>
<div class="tnp-field tnp-field-button"><input class="tnp-submit" type="submit" value="Subscribe" >
</div>
</form>
</div>
</section><section id="categories-7" class="widget widget_categories"><h4 class="widget-title">Navigate peppe8o.com</h4><form action="https://peppe8o.com" method="get"><label class="screen-reader-text" for="cat">Navigate peppe8o.com</label><select  name='cat' id='cat' class='postform' >
<option value='-1'>Select Category</option>
<option class="level-0" value="232">Arduino&nbsp;&nbsp;(7)</option>
<option class="level-0" value="2">Docker&nbsp;&nbsp;(10)</option>
<option class="level-0" value="132">ICT&nbsp;&nbsp;(2)</option>
<option class="level-0" value="3">media center&nbsp;&nbsp;(4)</option>
<option class="level-0" value="4">mining&nbsp;&nbsp;(2)</option>
<option class="level-0" value="5">raspberry&nbsp;&nbsp;(50)</option>
<option class="level-0" value="1">Uncategorised&nbsp;&nbsp;(5)</option>
<option class="level-0" value="8">websites&nbsp;&nbsp;(9)</option>
</select>
</form>
<script data-phast-original-type="text/javascript" type="text/phast">(function(){var dropdown=document.getElementById("cat");function onCatChange(){if(dropdown.options[dropdown.selectedIndex].value>0){dropdown.parentNode.submit();}}
dropdown.onchange=onCatChange;})();</script>
</section>
</section>
</div>
<div id="footer" class="footer-wrap">
<footer id="colophon" class="site-footer container clearfix" role="contentinfo">
<div id="footer-line" class="site-info">
<span class="credit-link">
WordPress Theme: Donovan by <a href="https://themezee.com/" target="_blank" rel="nofollow">ThemeZee</a>. </span>
</div>
</footer>
</div>
</div>
<div id="cookie-law-info-bar"><span>This website uses cookies to improve your experience. We'll assume you're ok with this, but you can opt-out if you wish.<a role='button' tabindex='0' data-cli_action="accept" id="cookie_action_close_header"  class="medium cli-plugin-button cli-plugin-main-button cookie_action_close_header cli_action_button" style="display:inline-block;  margin:5px; ">Accept</a> <a role='button' tabindex='0' id="cookie_action_close_header_reject"  class="medium cli-plugin-button cli-plugin-main-button cookie_action_close_header_reject cli_action_button"  data-cli_action="reject" style="margin:5px;" >Reject</a> <a href='https://peppe8o.com///privacy-policy-2/' id="CONSTANT_OPEN_URL" target="_blank"  class="cli-plugin-main-link"  style="display:inline-block; margin:5px; " >Read More</a></span></div><div id="cookie-law-info-again" style="display:none;"><span id="cookie_hdr_showagain">Privacy & Cookies Policy</span></div><div class="cli-modal" id="cliSettingsPopup" tabindex="-1" role="dialog" aria-labelledby="cliSettingsPopup" aria-hidden="true">
<div class="cli-modal-dialog" role="document">
<div class="cli-modal-content cli-bar-popup">
<button type="button" class="cli-modal-close" id="cliModalClose">
<svg class="" viewBox="0 0 24 24"><path d="M19 6.41l-1.41-1.41-5.59 5.59-5.59-5.59-1.41 1.41 5.59 5.59-5.59 5.59 1.41 1.41 5.59-5.59 5.59 5.59 1.41-1.41-5.59-5.59z"></path><path d="M0 0h24v24h-24z" fill="none"></path></svg>
<span class="wt-cli-sr-only">Close</span>
</button>
<div class="cli-modal-body">
<div class="cli-container-fluid cli-tab-container">
<div class="cli-row">
<div class="cli-col-12 cli-align-items-stretch cli-px-0">
<div class="cli-privacy-overview">
<div class="cli-privacy-content">
<div class="cli-privacy-content-text"></div>
</div>
<a class="cli-privacy-readmore" data-readmore-text="Show more" data-readless-text="Show less"></a> </div>
</div>
<div class="cli-col-12 cli-align-items-stretch cli-px-0 cli-tab-section-container">
<div class="cli-tab-section">
<div class="cli-tab-header">
<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="necessary" data-toggle="cli-toggle-tab" >
Necessary
</a>
<span class="cli-necessary-caption">Always Enabled</span> </div>
<div class="cli-tab-content">
<div class="cli-tab-pane cli-fade" data-id="necessary">
<p></p>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="cli-modal-backdrop cli-fade cli-settings-overlay"></div>
<div class="cli-modal-backdrop cli-fade cli-popupbar-overlay"></div>
<script data-phast-original-type="text/javascript" type="text/phast">cli_cookiebar_settings='{"animate_speed_hide":"500","animate_speed_show":"500","background":"#FFF","border":"#b1a6a6c2","border_on":false,"button_1_button_colour":"#000","button_1_button_hover":"#000000","button_1_link_colour":"#fff","button_1_as_button":true,"button_1_new_win":false,"button_2_button_colour":"#333","button_2_button_hover":"#292929","button_2_link_colour":"#444","button_2_as_button":false,"button_2_hidebar":false,"button_3_button_colour":"#000","button_3_button_hover":"#000000","button_3_link_colour":"#fff","button_3_as_button":true,"button_3_new_win":false,"button_4_button_colour":"#000","button_4_button_hover":"#000000","button_4_link_colour":"#fff","button_4_as_button":true,"font_family":"inherit","header_fix":false,"notify_animate_hide":true,"notify_animate_show":false,"notify_div_id":"#cookie-law-info-bar","notify_position_horizontal":"right","notify_position_vertical":"bottom","scroll_close":false,"scroll_close_reload":false,"accept_close_reload":false,"reject_close_reload":false,"showagain_tab":true,"showagain_background":"#fff","showagain_border":"#000","showagain_div_id":"#cookie-law-info-again","showagain_x_position":"100px","text":"#000","show_once_yn":false,"show_once":"10000","logging_on":false,"as_popup":false,"popup_overlay":true,"bar_heading_text":"","cookie_bar_as":"banner","popup_showagain_position":"bottom-right","widget_position":"left"}';</script><div id="amzn-assoc-ad-ad501ec9-4e40-46b3-b528-d11a5fc9c0f6"></div><script type="text/phast" async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&amp;adInstanceId=ad501ec9-4e40-46b3-b528-d11a5fc9c0f6"></script> <div id="fb-root"></div>
<script data-phast-original-src="https://peppe8o.com/wp-includes/js/comment-reply.min.js?ver=5.3.2" data-phast-params='{"ref":"W23LCTMtHgs"}' data-phast-original-type="text/javascript" type="text/phast"></script>
<script data-phast-original-type="text/javascript" type="text/phast">var q2w3_sidebar_options=[{"sidebar":"sidebar-1","margin_top":10,"margin_bottom":0,"stop_id":"","screen_max_width":0,"screen_max_height":0,"width_inherit":false,"refresh_interval":1500,"window_load_hook":false,"disable_mo_api":false,"widgets":["newsletterwidget-5","categories-7"]}];</script>
<script data-phast-original-src="https://peppe8o.com/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js?ver=5.1.9" data-phast-params='{"ref":"YWgRwkDEHJA"}' data-phast-original-type="text/javascript" type="text/phast"></script>
<script data-phast-original-src="https://peppe8o.com/wp-content/plugins/super-socializer/js/front/social_login/general.js?ver=7.12.40" data-phast-params='{"ref":"ae28ptn9RpI"}' data-phast-original-type="text/javascript" type="text/phast"></script>
<script data-phast-original-src="https://peppe8o.com/wp-content/plugins/super-socializer/js/front/facebook/sdk.js?ver=7.12.40" data-phast-params='{"ref":"UhMJrOJu23w"}' data-phast-original-type="text/javascript" type="text/phast"></script>
<script data-phast-original-src="https://peppe8o.com/wp-content/plugins/super-socializer/js/front/facebook/commenting.js?ver=7.12.40" data-phast-params='{"ref":"Q7unWoFQs7A"}' data-phast-original-type="text/javascript" type="text/phast"></script>
<script data-phast-original-src="https://peppe8o.com/wp-content/plugins/super-socializer/js/front/sharing/sharing.js?ver=7.12.40" data-phast-params='{"ref":"LG0f5TMt4sQ"}' data-phast-original-type="text/javascript" type="text/phast"></script>
<script data-phast-original-type="text/javascript" type="text/phast">var newsletter={"messages":{"email_error":"Email address is not correct","name_error":"Name is required","surname_error":"Last name is required","profile_error":"A mandatory field is not filled in","privacy_error":"You must accept the privacy policy"},"profile_max":"20"};</script>
<script data-phast-original-src="https://peppe8o.com/wp-content/plugins/newsletter/subscription/validate.js?ver=6.5.7" data-phast-params='{"ref":"_6Ao3LbxOBU"}' data-phast-original-type="text/javascript" type="text/phast"></script>
<script data-phast-original-type="text/javascript" type="text/phast">var a3_lazyload_params={"apply_images":"1","apply_videos":"1"};</script>
<script data-phast-original-src="https://peppe8o.com/wp-content/plugins/a3-lazy-load/assets/js/jquery.lazyloadxt.extra.min.js?ver=2.3.2" data-phast-params='{"ref":"Y5H8e22IhHc"}' data-phast-original-type="text/javascript" type="text/phast"></script>
<script data-phast-original-src="https://peppe8o.com/wp-content/plugins/a3-lazy-load/assets/js/jquery.lazyloadxt.srcset.min.js?ver=2.3.2" data-phast-params='{"ref":"yTG6wEzpOtU"}' data-phast-original-type="text/javascript" type="text/phast"></script>
<script data-phast-original-type="text/javascript" type="text/phast">var a3_lazyload_extend_params={"edgeY":"0","horizontal_container_classnames":""};</script>
<script data-phast-original-src="https://peppe8o.com/wp-content/plugins/a3-lazy-load/assets/js/jquery.lazyloadxt.extend.js?ver=2.3.2" data-phast-params='{"ref":"UVC4p82oPoc"}' data-phast-original-type="text/javascript" type="text/phast"></script>
<script data-phast-original-src="https://peppe8o.com/wp-includes/js/wp-embed.min.js?ver=5.3.2" data-phast-params='{"ref":"E7r9QpzanVI"}' data-phast-original-type="text/javascript" type="text/phast"></script>
<script data-phast-compiled-js-names="ScriptsProxyService/rewrite-function.js,CSSInlining/ie-fallback.js,CSSInlining/inlined-css-retriever.js,ScriptsDeferring/scripts-loader.js,ScriptsDeferring/rewrite.js">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</script></body>
</html><!-- [Phast] Document optimized in 35ms -->
<!-- WP Fastest Cache file was created in 0.96234893798828 seconds, on 26-03-20 19:30:31 -->